Symptom

This error occurs when updating your My Genius device/software


Cause

There are several reasons:

1. My Genius tool with blocked ABL (authorizations).

2. The software can't reach Dimsport servers.

3. Obsolete software version.

4. Your firewall/antivirus/antimalware/proxy/antispyware etc. is blocking the access to Dimsport servers.

5. Mirror not reachable.

6. Virgin My Genius tool with no authorizations. 

7. My Genius tool with old GOS (Genius  Operating System)

8. FTDII and SD Card CID (respectively the ID number of the USB interface and SD Card) are corrupted (they don't correspond to the original ones)

Solution

1. Check your internet connection, change it with a new one or use a mobile hotspot

2. Perform an update of your My Genius device/software.

3. Disable your firewall/antivirus/antimalware/proxy/antispyware etc.

4. Change the Mirror as the following https://reserved.dimsport.com/kb/Article.aspx?id=1136.

If the proposed solutions don't work, contact your Master